Go to advanced search

by NilsUppsala
Thu Dec 27, 2018 4:41 pm
Forum: Automation, sensing and robotics
Topic: Using RasPiGNSS for RTK purposes
Replies: 0
Views: 612

Using RasPiGNSS for RTK purposes

Trying to use bcm2835 to use I/O on my Pi I get message like: pi@raspberrypi:~ $ sudo nvsctl -v init Can't locate Device/BCM2835.pm in @INC (you may need to install the Device::BCM2835 module) (@INC contains: /bin/../lib /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/...
by NilsUppsala
Thu Dec 27, 2018 9:39 am
Forum: Beginners
Topic: PuTTY Fatal Error Why?
Replies: 3
Views: 411

Re: PuTTY Fatal Error Why?

Thank you, that fixed it! :D
by NilsUppsala
Wed Dec 26, 2018 2:00 pm
Forum: General programming discussion
Topic: Removing pullup/pulldown on a RPi Zero
Replies: 6
Views: 1742

Re: Removing pullup/pulldown on a RPi Zero

I give up! Added 10k resistor so I get 2,86 volt on the pin, that aught to do it.
Thanks again, Joan
by NilsUppsala
Wed Dec 26, 2018 1:18 pm
Forum: Beginners
Topic: PuTTY Fatal Error Why?
Replies: 3
Views: 411

PuTTY Fatal Error Why?

When trying to connect to my RPiZeroW via PuTTY I get the answer:
Disconnected: Server protocol violation: unexpected SSH2_MSG_UNIMPLEMENTED packet.
Yes, I have SSH enabled. Help someone!!
by NilsUppsala
Wed Dec 26, 2018 12:37 pm
Forum: General programming discussion
Topic: Removing pullup/pulldown on a RPi Zero
Replies: 6
Views: 1742

Re: Removing pullup/pulldown on a RPi Zero

Thank you Joan, I have been thinking doing my own pull-up as to your suggestion but it is a not a clean (software) solution. I have been looking at doc's: https://www.raspberrypi.org/documentation/configuration/pin-configuration.md https://www.raspberrypi.org/documentation/configuration/config-txt/g...
by NilsUppsala
Wed Dec 26, 2018 10:32 am
Forum: General programming discussion
Topic: Removing pullup/pulldown on a RPi Zero
Replies: 6
Views: 1742

Re: Removing pullup/pulldown on a RPi Zero

My RPiZeroW has a PULLDOWN on pin 12 i.e. GPIO18 which pull the reset down on my RasPiGNSS module. I have not been able to get rid of that pulldown. How to do that??
by NilsUppsala
Thu Dec 20, 2018 12:06 pm
Forum: General programming discussion
Topic: Removing pullup/pulldown on a RPi Zero
Replies: 6
Views: 1742

Removing pullup/pulldown on a RPi Zero

Hi, I have spent a few days (!!!) trying to get rid of the pullup/pulldown on my R Pi Zero W . Using rpio i get the answer it only works on Raspberry Pi's. It gets very frustrating after a while. So how to remove this preferably from the command line? Please help me solve this before Christmas!! wis...
by NilsUppsala
Fri May 04, 2018 2:30 pm
Forum: Graphics programming
Topic: Making a Webpage from a glade-made app in RPii
Replies: 1
Views: 866

Making a Webpage from a glade-made app in RPii

I have a table made with help of glade running on my RPi3. I want to show that table (with dynamic info) via a web server on the same RPi. Where can i find a simple tutorial for this specific subject? Please point me in the right direction!
Nils
by NilsUppsala
Sat Sep 30, 2017 11:59 am
Forum: Troubleshooting
Topic: RPi3: Bluetooth away, cannot get UART0 going
Replies: 1
Views: 229

After hours of tries I began seeing the light, I am now using ttyAMA0. But what I have been reading, it ought to be ttyS0 when I steal the UART from Bluetooth??
I now consider this thread ended, at least regarding myself!!
by NilsUppsala
Fri Sep 29, 2017 9:20 am
Forum: Troubleshooting
Topic: RPi3: Bluetooth away, cannot get UART0 going
Replies: 1
Views: 229

RPi3: Bluetooth away, cannot get UART0 going

I attempt to use UART0 for my ZigBee talking to 7 other ZigBee's. It is not working. So connecting pins 8 and 10 together, sending a string and not receiving anything back I start to wonder: are pins 8 and 10 correct? Am I to use ttyS0 or ttyAMA0. I have a fair amount of experience with serial com o...
by NilsUppsala
Fri Sep 29, 2017 7:17 am
Forum: C/C++
Topic: Closing serial port when doing ^C
Replies: 4
Views: 2094

Closing serial port when doing ^C

I open a serial port in a program. After breaking my program with ^C the serial port is locked.so when I try to run again I get -1 when attempting to open the port. Two things I would like to know: How to close an earlier opened port using CL. Can I detect ^C when in a loop so I can close the port b...
by NilsUppsala
Thu Sep 28, 2017 5:56 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: trying to get rid of bluetooth and use that serial input on RPi3
Replies: 2
Views: 547

Re: trying to get rid of bluetooth and use that serial input on RPi3

Yes, I probably got rid of the bluetooth but my serial com is a no-go. I can open the ttyS0 and I listen with RealTerm so I know there is data coming. And the software HAVE been functioning... So I did leave ttyUSB-input unnecessarily. Well, new energy for this tomorrow, perhaps... Thanks for trying...
by NilsUppsala
Thu Sep 28, 2017 3:42 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: trying to get rid of bluetooth and use that serial input on RPi3
Replies: 2
Views: 547

trying to get rid of bluetooth and use that serial input on RPi3

Trying to find info howto disconnect bluetooth and connect serial com stuff to the right pins (which ones?) Have tried with USB serial but it is not stable. Can anyone please point me in the right direction for easy-to-follow instructions?
Nils
by NilsUppsala
Mon Sep 25, 2017 3:10 pm
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

...and it run! So thank you SOOO much!
I have been struggling with this on and off for three weeks b4 trying the RPi forum!

Best 73 and c u on 80?

PS whatever is PI2 XENON DEATH FLASH!???? DS
by NilsUppsala
Mon Sep 25, 2017 2:43 pm
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

No I didn't but now I did! A LOT of nice ham pic's! I am a ham , B lic 1962 and A lic 1963 so I have been around the bands a bit to! I am the co-designer of Qrolle, a 5 band QRP-transceiver (http://qrolle.thulesius.se/) I did the software and the design of the digital part (AT91SAM7X256-cpu) I think...
by NilsUppsala
Mon Sep 25, 2017 11:52 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

I discovered my mistake, incorrect ending of the subroutine declaration. posting.php?mode=reply&f=32&t=193982#
nils et sm5deh
by NilsUppsala
Mon Sep 25, 2017 11:32 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

Hi and thank you AGAIN! Been trying to reach your high standards, not a chance! I have been trying to adapt the link content you sent me, I can't get it going. Big error sign and message pFriggeInneVarning.set_text ("50.4") AttributeError: 'NoneType object has no attribute 'set_text' After my last a...
by NilsUppsala
Mon Sep 25, 2017 9:11 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

Thank you again! I did a stupid error, i have some corrections to do in my Glade file! I aught to have detected that myself! My application is as follows: i have 10 external devices sending my RPi data via ZigBee transceivers. I collect the data and transform them to files in a separate routine in R...
by NilsUppsala
Mon Sep 25, 2017 8:32 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

Thankyou! Will try! Nice beard!
Nils
by NilsUppsala
Mon Sep 25, 2017 8:14 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

Re: PyGtk and Glade, cannot connect to the GUI!

Thanks PeterO!
I must have misunderstood what a widget is, an Entry box is not it obviously! Can you give me a clue how to change it, please? (Aren't all the icons depicted in Glade widgets?)
Nils, beginner in Glade...
by NilsUppsala
Mon Sep 25, 2017 7:32 am
Forum: Python
Topic: PyGtk and Glade, cannot connect to the GUI!
Replies: 13
Views: 1289

PyGtk and Glade, cannot connect to the GUI!

Hi all, i have been trying to write into a Entry widget and i cannot address it? How do i write into the Entry box with ID FriggeInneVarning , or ANY other box in my Gtk-file? My python code: #!/usr/bin/python import gi gi.require_version('Gtk', '3.0') from gi.repository import Gtk class Handler: de...
by NilsUppsala
Fri Apr 28, 2017 7:13 pm
Forum: Interfacing (DSI, CSI, I2C, etc.)
Topic: Bluetooth connection not accepted
Replies: 1
Views: 382

Bluetooth connection not accepted

I try to connect an accepted bluetooth USB-UART dongle to my RPi 3 Bluetooth . The RPi insists that the connection failed due to "No usable services on this device" The device in question is set up as a SPP (serial port device). Listing the dongles setup it displays SPP as active. And that is what I...
by NilsUppsala
Mon Jan 25, 2016 2:09 pm
Forum: Python
Topic: setting ETSConfig.toolkit = 'qt4'
Replies: 1
Views: 537

setting ETSConfig.toolkit = 'qt4'

Hi, when trying to install Swift Navigation's GPS console for Linux I get an error: ValueError: cannot set toolkit to qt4 because it has already been set to wx pi@raspberrypi:~/piksi_tools $ So how do I set the ETSConfig.toolkit to 'qt4' in RaspberryPi for Python2.7?? I am using the Jessie version O...
by NilsUppsala
Wed Apr 02, 2014 7:02 pm
Forum: Troubleshooting
Topic: Stops at boot after a while
Replies: 2
Views: 520

Re: Stops at boot after a while

Thanks!
I reloaded the OS onto the SD and took the time to reload all the apps again. After a day's work it was done! So this thread is now closed, n'est pas? :roll:
by NilsUppsala
Mon Mar 31, 2014 4:51 pm
Forum: Troubleshooting
Topic: Stops at boot after a while
Replies: 2
Views: 520

Stops at boot after a while

After a few restarts: Stops at "Setting up X socket directories... /tmp/.X11-unix /tmp/.ICE-unix." and nothing more, forever(?) Have been looking through "boot sticky", cannot find any help there. Where have I done wrong?? :oops: Have been restarting several times, NOOBS do not start (too early in t...

Go to advanced search