Go to advanced search

by MrEngman
Sat Dec 14, 2019 11:25 am
Forum: Français
Topic: Se connecter avec un dongle netgear wda-131 dans raspbian buster
Replies: 15
Views: 264

Re: Se connecter avec un dongle netgear wda-131 dans raspbian buster

Désolé mais je ne parle pas français. I use Google translate. If you install Raspbian Buster on your SD card you do not need to make any changes to get your wifi working. The wifi driver for your wifi dongle is included in the Buster image and you do not need add any other files except make file wpa...
by MrEngman
Fri Dec 13, 2019 11:20 pm
Forum: Français
Topic: Se connecter avec un dongle netgear wda-131 dans raspbian buster
Replies: 15
Views: 264

Re: Se connecter avec un dongle netgear wda-131 dans raspbian buster

Pour "Bus 001 Device 004: ID 07d1:3303 D-Link System DWA-131 802.11n Wireless N Nano Adapter(rev.A1) [Realtek RTL8192SU]" Raspbian - driver file = r8712u pi@Pi-2B-c:~ $ modinfo r8712u filename: /lib/modules/4.19.86-v7+/kernel/drivers/staging/rtl8712/r8712u.ko firmware: rtlwifi/rtl8712u.bin author: L...
by MrEngman
Fri Dec 13, 2019 7:45 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

(SOLVED) Re: command line does not show coloured text for prompt, dirs, scripts etc.

Thank you very much trejan,

Setting .profile as you suggest works.



MrEngman
by MrEngman
Fri Dec 13, 2019 7:04 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

I'm running Raspbian Lite, no gui or no lxterminal anyway. That would have been helpful to state in the original post. You said your TERM variable was set to xterm which implies running the full GUI but if you're running Raspbian Lite then something weird is going on. It should be "linux" if you're...
by MrEngman
Fri Dec 13, 2019 5:25 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Yeah. The .bashrc file is fine which is why when you run bash again it gives you the colours. The problem is that the bash spawned by lxterminal isn't running in interactive mode. Not sure why though. If you run lxterminal, it should spawn a new window. Does this bash have colour? Is this a custom ...
by MrEngman
Fri Dec 13, 2019 5:05 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

.bashrc and .profile look as you expect. pi@Pi-3B-plus:~ $ ls -l .bashrc .profile -rw-r--r-- 1 pi pi 3523 Dec 13 14:42 .bashrc -rw-r--r-- 1 pi pi 675 Mar 13 2018 .profile bash -v shows pi@Pi-3B-plus:~ $ bash -v # System-wide .bashrc file for interactive bash(1) shells. # To enable the settings / com...
by MrEngman
Fri Dec 13, 2019 5:01 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Just run the command bash and lo and behold the text colours are now working. No idea what is causing the issue but that command fixed it, temporarily. Rebooting and the text is back to all white again. Running bash again and the colours for the prompt, dirs., scripts etc. return. Hopefully that may...
by MrEngman
Fri Dec 13, 2019 4:48 pm
Forum: Beginners
Topic: TP-Link AC600 T2U plus - No driver in kernel?
Replies: 15
Views: 906

Re: TP-Link AC600 T2U plus - No driver in kernel?

Ooops, apparently one of the USB-ports does not work with the new stick, but with the Ralink stick. The other USB-port is working just fine for both sticks! rctl show bridge name bridge id STP enabled interfaces br0 8000.34e894b57316 no eth0 wlan0 Very strange... I had a similar problem several yea...
by MrEngman
Fri Dec 13, 2019 4:43 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Does $HOME/.profile exist? Stock copy is /etc/skel/.profile Yes # ~/.profile: executed by the command interpreter for login shells. # This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login # exists. # see /usr/share/doc/bash/examples/startup-files for examples. # the files are locate...
by MrEngman
Fri Dec 13, 2019 3:41 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Code: Select all

pi@Pi-3B-plus:~ $echo $SHELL
/bin/bash
pi@Pi-3B-plus:~ $


MrEngman
by MrEngman
Fri Dec 13, 2019 2:59 pm
Forum: Beginners
Topic: TP-Link AC600 T2U plus - No driver in kernel?
Replies: 15
Views: 906

Re: TP-Link AC600 T2U plus - No driver in kernel?

The lsusb command doesn't show you wifi dongle so some issue with the USB. Make sure it's connected OK.

Maybe power down the Pi, turn of the PSU, wait a while and then power on and reboot and see if that fixes it.


MrEngman
by MrEngman
Fri Dec 13, 2019 2:49 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

$HOME/.bashrc contains the section you showed.

I copied /etc/skel/.bashrc to $HOME/.bashrc but it makes no difference. Rebooted just in case I needed to but the problem still exists.



MrEngman
by MrEngman
Fri Dec 13, 2019 2:35 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Looks like this may well be the issue. alias shows nothing.

Code: Select all

pi@Pi-3B-plus:~ $alias
pi@Pi-3B-plus:~ $

MrEngman
by MrEngman
Fri Dec 13, 2019 2:30 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

It exists and appears to run pi@Pi-3B-plus:~ $dircolors LS_COLORS='rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:...
by MrEngman
Fri Dec 13, 2019 2:14 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

Re: command line does not show coloured text for prompt, dirs, scripts etc.

Somebody/something changed $TERM? No idea what that is, however, command pi@Pi-3B-plus:~ $echo $TERM xterm pi@Pi-3B-plus:~ $ shows the same on the faulty Pi 3B+ as above and on my other Pi's . e.g working Pi Zero pi@Pi-0-b:~ $ echo $TERM xterm pi@Pi-0-b:~ $ EDIT: Looking at xterm it appears to be t...
by MrEngman
Fri Dec 13, 2019 1:32 pm
Forum: Troubleshooting
Topic: (SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.
Replies: 23
Views: 264

(SOLVED) command line does not show coloured text for prompt, dirs, scripts etc.

Hi, For some reason on one of my Pi's the command line is now only showing white text on a black background. $PS1 and $LS_COLORS show pi@Pi-3B-plus:~$ echo $PS1 ${debian_chroot:+($debian_chroot)}\u@\h:\w\$ pi@Pi-3B-plus:~$ echo $LS_COLORS pi@Pi-3B-plus:~$ I've no idea why this suddenly happened and ...
by MrEngman
Thu Dec 12, 2019 5:58 am
Forum: Troubleshooting
Topic: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+
Replies: 1406
Views: 1332307

Re: (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.xx.xx+

what can I do if I'm making my own kernel? I had cooked a new kernel based on 4.19.86+, after a successful compiling, I installed the 4.19.86+ driver (I am compiling kernel for pi Zero), but the driver (8188eu.ko) failed to load, it just said Invalid module format. I think the build number of the k...
by MrEngman
Tue Dec 10, 2019 7:58 pm
Forum: Français
Topic: Se connecter avec un dongle netgear wda-131 dans raspbian buster
Replies: 15
Views: 264

Re: Se connecter avec un dongle netgear wda-131 dans raspbian buster

je suis désolé je ne parle pas français ne modifiez pas le fichier /etc/network/interfaces # interfaces(5) file used by ifup(8) and ifdown(8) # Please note that this file is written to be used with dhcpcd # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf' # Include files from /etc/netwo...
by MrEngman
Mon Dec 09, 2019 7:48 pm
Forum: General discussion
Topic: Out of tree wifi drivers for Pi4 64 bit OS
Replies: 0
Views: 58

Out of tree wifi drivers for Pi4 64 bit OS

Hi, For anyone who may be interested I'm now compiling my wifi drivers for Pi4 64 bit OS. 8188eu, 8188fu, 8192eu, 8812au and 8822bu drivers are available for Raspbian OS 4.19.xx-v8+ 64 bit. Driver files are available from here Download and installation details available here either by direct manual ...
by MrEngman
Mon Dec 09, 2019 5:48 pm
Forum: General discussion
Topic: How Do I Connect To A PEAP Network On Raspbian?
Replies: 1
Views: 74

Re: How Do I Connect To A PEAP Network On Raspbian?

Try this -

Code: Select all

man 5 wpa_supplicant
- example 2


MrEngman
by MrEngman
Thu Dec 05, 2019 4:27 pm
Forum: Troubleshooting
Topic: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed
Replies: 7
Views: 155

Re: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed

So you may need to run command

Code: Select all

rfkill unblock wlan
to enable your wifi.


MrEngman
by MrEngman
Thu Dec 05, 2019 3:57 pm
Forum: Troubleshooting
Topic: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed
Replies: 7
Views: 155

Re: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed

I'm fairly certain that the country code was a requirement for using the wifi with the buster OS. One other item that needed using when buster was first introduced was rfkill . rfkill shows whether the wifi and Bluetooth drivers are enabled or not. e.g Pi 4B shows pi@Pi-4-a:~ $ rfkill ID TYPE DEVICE...
by MrEngman
Wed Dec 04, 2019 5:13 pm
Forum: Troubleshooting
Topic: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed
Replies: 7
Views: 155

Re: USB Wi-Fi card on Raspberry Pi 2 doesn't work even with drivers installed

Hi ZXY007o0ePksrW7L, All you should need to do is set up /etc/wpa_supplicant/wpa_supplicant.conf correctly to get the wifi working. It should look like ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 country=GB network={ ssid="wifi-name" psk="wifi-password" key_mgmt=WPA-PSK }...
by MrEngman
Sat Nov 30, 2019 9:34 pm
Forum: Beginners
Topic: Pi Zero W no WIFI
Replies: 9
Views: 196

Re: Pi Zero W no WIFI

The info you posted says your Pi is a Pi Zero, not a Pi Zero W. Check revision code here

So no built in wifi.


MrEngman
by MrEngman
Fri Nov 29, 2019 7:19 pm
Forum: Troubleshooting
Topic: Help with AWUS036ACH
Replies: 11
Views: 351

Re: Help with AWUS036ACH

R.P.M. wrote:
Fri Nov 29, 2019 6:54 pm
Dear MrEngman

You have been a true legend once again! Acces Point mode works perfect, driver install was smooth and guidance was excellent. You are a gem!
Thank you R.P.M.

Good to hear I was able to help you get your wifi working.


MrEngman

Go to advanced search